Issue with RTD

Nov 12, 2012 at 11:44 AM

Hi,

First off may I add my congratulations for what is a brilliant project !

I have had what sounds like an identical issue with RTD to the 'Issue with Ribbon' topic - in that the RTD sample was failing on my machine due to me not having permissions to write to HKEY_CURRENT_USER\Software\Classes. The example did not work and Excel crashed on exit - if I debugged with Visual Studio I got the exception 'cannot access' the registry key.

The sample worked on every other machine I tried (6 others), and the sysadmin agreed that everyone should have full control of HKEY_CURRENT_USER\ but could not offer an explanation as to why my rights were not there. Adding permission solved the problem.

I would like ExcelDNA to test the registry write and give a more sensible error mesage when it fails, if possible. Hopefully the crash at Excel exit could also be eliminated.

Thanks,

David

 
Coordinator
Nov 12, 2012 at 5:43 PM

Hi David,

OK, I am able to recreate the Excel crash on close.

I'll have a closer look...

-Govert