Problems with Ribbon enabled Add-In

Jan 2, 2013 at 11:08 AM

Hi and a happy new Year,

I'm using ExcelDNA 0.30 stable, Excel 2010 (32Bit) on a Win7 (64Bit) machine.

I've wrote an Add-In class in VB.NET (VSExpress 2012), which inherits ExcelRibbon.

Everything's works fine until the mid of last December. Probably the date doesn't matter ;-)

Now, I can't see the Ribbon and contextmenues anymore.

Excel says nothing, except some "ExcelDna.Loader.DnaMarshalException" and "System.Reflection.TargetInvocationException" in mscorlib.dll and ExcelDna.Integration.

I've testet some older versions of my Add-In but I get the same behaviour. I'm wondering.

I tried to start a new Add-In Project and installed the ExcelDNA through the NuGet Packetmanager and with a minimal XML-output from the overridden GetCustomUI function.

The same result. No Ribbon appears. :-(

So, I'm a little bit despaired and I hope, some one can help me, please.

Thank you very much.

P.S.: Sorry for my terrible English.
       The Ribbon-Class is ComVisible, I'm compiling for x86 and the NEW procedure is invoked.

Jan 2, 2013 at 3:25 PM

I've replied to the Google group discussion: