Packaged XLL Opening issue

Jan 29, 2015 at 12:33 PM

I'm evaluating ExcelDNA as a possible alternative to our current VBA based development approach.
It's looking quite good but have come across a blocker.
It uses a packaged 32-bit XLL file with an embedded .xlsm file. In the AutoOpen event it extracts the xlsm and loads it as a workbook. Along with this it's got some UDFs and custom ribbon buttons.

The problem I'm facing is while opening this XLL on a workstation. I was initially getting Digital Signature error but even after relaxing the security settings to allow all macros it doesn't seem to be firing the AutoOpen event. The ribbon tab is also not appearing and can't see any errors.

I've even tried signing the xll with a self generated certificate but still no luck. (followed guidance from

It all works fine on my development machine and I can't seem to find the difference.

Any thoughts?
Feb 2, 2015 at 8:21 AM
Some steps if your add-in is not loading at all, with no error message displayed:
  • Check that VBA support is installed - it is an optional feature. Just press Alt+F11 and check that the VBA IDE is displayed.
  • Check the "Macro settings" security options (there are various security settings). Set this to "Disable all macros with notification". When loading an .xll you should be prompted whether to enable it or not, which at least tells you that something is happening.
  • Check the sample add-in in the distribution - just File->Open the Distribution\ExcelDna.xll file. Do you get the loading prompt and then the =AddThem(...) function?
Feb 4, 2015 at 11:10 AM
Thanks for the response Govert and I must appreciate your work on this product, it's a great tool.

I finally got to the bottom of why it wasn't opening and I must admit it was annoying. Turned out that I was using .NET 4.5 async/await and one of these client workstations only had .NET 4. Aghhhhh...

frustrating, some sort of error somewhere would have been helpful :)