.NET Framework 4.5.1 Preview

Aug 6, 2013 at 9:05 AM
Hi
I have .NET Framework 4.5.1 Preview installed.
The .dna file contains the following DnaLibrary tag:

<DnaLibrary RuntimeVersion="v4.5.1 Preview">

I get an error message from the Add-In Loader which tells me
"This Excel add-in requires the Microsoft .NET Framework."
I have also tried:
RuntimeVersion="v4.5.1" and RuntimeVersion="v4.5"

but I get the same error message. What should I do?

Regards
Peter
Coordinator
Aug 6, 2013 at 3:07 PM
Hi Peter,

.NET 4.5 and .NET 4.5.1 are in-place updates of the .NET framework. As a result, the runtime version number does not change.
For all of these you'd use
RuntimeVersion="v4.0"
Whatever is the currently installed update will be loaded. If you need to handle the situation where a newer update is not installed, you need to check the registry yourself in your AutoOpen.

Regards,
Govert